API_​IClassificationSystemEventHandler

The base class you need to inherit from in case you want to handle API_ClassificationSystem events.

    class API_IClassificationSystemEventHandler : public API_IEventHandler {
    public:
        virtual void OnCreated (const GS::HashSet<API_Guid>& ids) const;
        virtual void OnModified (const GS::HashSet<API_Guid>& ids) const;
        virtual void OnDeleted (const GS::HashSet<API_Guid>& ids) const;
    };

 

Functions

OnCreated
Override this function to be notified of newly created Classification Systems.
OnModified
Override this function to be notified of modified Classification Systems.
OnDeleted
Override this function to be notified of deleted Classification Systems.

  

Requirements

Version: API 26 or later
Header: APIdefs_Callback.h

 

See Also

ACAPI_Notify_RegisterEventHandler
API_ClassificationSystem,
API Types