API_​IFCClassification

IFC classification structure.

    typedef struct {
        GS::OptionalGS::UniString>    source;
        GS::OptionalGS::UniString>    edition;
        GS::OptionalGS::UniString>    editionDate;
        GS::UniString                  name;
        GS::OptionalGS::UniString>    description;
        GS::OptionalGS::UniString>    location;
    } API_IFCClassification;

 

Members

source
source of classification
edition
edition of classification
editionDate
the date on which the edition of the classification used became valid
name
name of classification
description 25
description of the classification
location 25
resource identifier or locator of the classification

 

Remarks

This structure contains the data of an IfcClassification.

 

Requirements

Version: API 16 or later
Header: APIdefs_Elements.h

 

See Also

API_IFCClassificationReference