IFC classificationreference structure.
typedef struct { GS::UniString referenceName; bool readOnly; GS::OptionalGS::UniString> location; GS::OptionalGS::UniString> name; GS::OptionalGS::UniString> identification; API_IFCClassification referencedSource; } API_IFCClassificationReference;
Members
- referenceName
- name of the IfcRelAssociatesClassification
- readOnly
- whether the classificationreference is read-only on user interface
- location
- location of the classificationreference
- name
- name of the classificationreference
- identification
- identification of the classificationreference
- referencedSource
- referencedsource of the classificationreference
Remarks
This structure contains the data of an IfcClassificationReference.referenceName
is unique for classificationreferences of an element.
Requirements
- Version: API 16 or later
- Header: APIdefs_Elements.h