API_​IFCDifferenceGeneratorState

State used in IFCDifference Generator.

	typedef struct { 
        API_ElemDifferenceGeneratorState      elemDifferenceGeneratorState
        API_Guid                              environmentChecksum;
        API_IFCRelationshipData               ifcRelationshipData;
        GS::HashTable<API_Guid, API_Guid>     elementIDToIFCGlobalId;
    } API_IFCDifferenceGeneratorState;

 

Members

elemDifferenceGeneratorState 
Element Difference Generator state.
environmentChecksum 
Environment checksum calculated from IFC Translator name, IFC Translator settings, IfcBuildingStorey core data, etc.
ifcRelationshipData 
IFC Relationship Data.
elementIDToIFCGlobalId 
ArchiCAD Guid and IFC Global Id table.

 

This Structure describes an ArchiCAD project state, witch can be used to generate IFC Difference.

 

Requirements

Version: API 23 or later
Header: APIdefs_IFC.h

 

See Also

ACAPI_IFC_GetIFCDifference,
ACAPI_IFC_GetIFCDifferenceState,
API Types