API_​IFCProperty

IFC property container structure.

    typedef struct {
        API_IFCPropertyHead                head;
        API_IFCPropertySingleValue         singleValue;
        API_IFCPropertyBoundedValue        boundedValue;
        API_IFCPropertyListValue           listValue;
        API_IFCPropertyEnumeratedValue     enumeratedValue;
        API_IFCPropertyTableValue          tableValue;
    } API_IFCProperty;

 

Members

head
Property header information
singleValue
IfcPropertySingleValue values
boundedValue
IfcPropertyBoundedValue values
listValue
IfcPropertyListValue values
enumeratedValue
IfcPropertyEnumeratedValue values
tableValue
IfcPropertyTableValue values

 

Remarks

This structure contains the data of an Ifc(Simple)Property.
head contains common information for each type.
head.propertyType determines which value member contains value data.

 

Requirements

Version: API 16 or later
Header: APIdefs_Elements.h

 

See Also

API_IFCPropertySingleValue, API_IFCPropertyListValue, API_IFCPropertyBoundedValue, API_IFCPropertyEnumeratedValue, API_IFCPropertyTableValue
API_IFCPropertyHead