API_​IFCPropertyAnyValue

IFC property base value data container.

    typedef struct {
        API_IFCPropertyValuePrimitiveType     primitiveType;
        double                                doubleValue;
        Int64                                 intValue;
        bool                                  boolValue;
        GS::UniString                         stringValue;
    } API_IFCPropertyAnyValue;

 

Members

primitiveType
Primitive type

API_IFCPropertyValuePrimitiveType

Meaning

API_IFCPropertyAnyValueIntegerType

Value is stored as an integer

API_IFCPropertyAnyValueRealType

Value is stored as a double

API_IFCPropertyAnyValueBooleanType

Value is stored as a boolean

API_IFCPropertyAnyValueLogicalType

Value is stored as an integer, see API_IFCPropertyValue for possible values

API_IFCPropertyAnyValueStringType

Value is stored as a string

doubleValue
Double value
intValue
Integer value
boolValue
Boolean value
stringValue
String value

 

Remarks

This structure contains the base value of an IFC property in one of it’s members.
The primitiveType field is an output parameter only, shall not be set when setting up a new API_IFCPropertyValue structure.

 

Requirements

Version: API 16 or later
Header: APIdefs_Elements.h

 

See Also

API_IFCPropertyValue