IFC property with a list of possible and selected value.
typedef struct { GS::Array<API_IFCPropertyValue> enumerationReference; GS::Array<API_IFCPropertyValue> enumerationValues; } API_IFCPropertyEnumeratedValue;
Members
- enumerationReference
- List of possible values of the property
- enumerationValues
- List of selected values of the property
Remarks
This structure contains the list of possible and selected values of an IfcPropertyEnumeratedValue.
All values shall have the same type.
The enumerationReference
shall contain all the values of enumerationValues
, which shall contain at least one value.
Requirements
- Version: API 16 or later
- Header: APIdefs_Elements.h