IFC property header structure.
typedef struct { GS::UniString propertySetName; GS::UniString propertyName; GS::UniString propertyDescription; API_IFCPropertyType propertyType; bool readOnly; } API_IFCPropertyHead;
Members
- propertySetName
- Name of the containing propertyset
- propertyName
- Name of the property
- propertyDescription
- Description of the property
- propertyType
-
Type of the IFC property
Meaning
API_IFCPropertySingleValueType
Property with a single value
API_IFCPropertyListValueType
Property with a list of values
API_IFCPropertyBoundedValueType
Property with a lowerbound and upperbound value
API_IFCPropertyEnumeratedValueType
Property with a list of possible and selected values
API_IFCPropertyTableValueType
Property with a list of value pairs
Remarks
This structure holds common information of all IFC Property types.propertyName
and propertySetName
shall not be empty strings.propertyName
and propertySetName
pairs of an element are unique.
Requirements
- Version: API 16 or later
- Header: APIdefs_Elements.h