The IfcPropertyReferenceValue allows a property value to be given by referencing other entities within the resource definitions of IFC.
typedef struct { GS::UniString usageName; API_IFCObjectReferenceType type; short day; short month; short year; } API_IFCPropertyReferenceValue;
Members
- usageName
- Description of the use of the referenced value within the property.
- type
-
Meaning
CalendarDate
A date which is defined by a day in a month of a year.
- day
- The day element of the calendar date.
- month
- The month element of the calendar date.
- year
- The year element of the calendar date.
Remarks
This structure contains a date which is defined by a day in a month of a year.
Requirements
- Version: API 17 or later
- Header: APIdefs_Elements.h