API_​IFCPropertyValue

IFC property value data container.

    typedef struct {
        API_IFCPropertyAnyValue     value;
        GS::UniString               valueType;
    } API_IFCPropertyValue;

 

Members

value
Base value container
valueType
IFC type of the value in string format

 

Remarks

This structure contains the value of an IFC property. The valueType field determines which field of the value structure contains the base value. Each IFC type has a primitive type, e.g. IfcLabel and IfcText both contain a string, IfcReal and IfcPositiveLengthMeasure both contain a real value and so on.

IfcLogical type is stored as an integer:

FALSE

0

UNKNOWN

1

TRUE

2

 

Requirements

Version: API 16 or later
Header: APIdefs_Elements.h

 

See Also

API_IFCPropertySingleValue, API_IFCPropertyListValue, API_IFCPropertyBoundedValue, API_IFCPropertyEnumeratedValue, API_IFCPropertyTableValue