The representation of the Imaging and Calculation tab page of the Work Environment dialog.
typedef struct { bool autoRebuild3D; bool activate3DOnChange; bool filler_1; bool keepZoomedSection; bool showProgressWindow; bool interruptOnError; bool progressSounds; bool generate3DReport; short reportLevel; short selElemsListing; Int32 filler_2 [5]; } API_ImagingAndCalcPrefs;
Members
- autoRebuild3D
- Rebuild the 3D window whenever it’s brought to the front
- activate3DOnChange
- Bring the 3D window to the front whenever the 3D Projection Settings or Rendering modes are changed
- keepZoomedSection
- Display previously magnified detail in the section window whenever the section window is rebuilt
- showProgressWindow
- Display the 3D progress information window
- interruptOnError
- Allow interruption of any imaging process
- progressSounds
- Enable sound indications of 3D processes
- generate3DReport
- Create a 3D Report window
- reportLevel
-
Value of the slider that defines one of four levels of detail for the 3D Report:
APIReportLevel_No
No Report APIReportLevel_Brief
Brief Report APIReportLevel_Short
Short Report APIReportLevel_Detailed
Detailed Report APIReportLevel_Full
Full Report - selElemsListing
-
Switch to define how to handle selected elements while listing:
APICalcSelElems_ShowAlert
Display warning dialog to choose listing method APICalcSelElems_ListAll
Calculate all selected elements in the list APICalcSelElems_UseFilters
Apply filters defined for the selected elements
Remarks
This structure is used by the APIEnv_GetPreferencesID function to get the settings of the Imaging and Calculation tab page of the Work Environment dialog.
Requirements
- Version: API 6.1 or later
- Header: APIdefs_Environment.h