An iterior elevation element.
typedef struct { API_Elem_Head head; API_CutPlaneShowType cutPlShow; short storyToShowOn; short filler_1; API_SectionSegment segment; bool useCommonMarker; bool filler_2[7]; API_Guid markerGuid; short markerPen; short markerFont; Int32 filler_3; double markerSize; double markerTextSize; UInt32 nSegments; Int32 nLineCoords; API_Polygon poly; Int32 filler_4[6]; } API_InteriorElevationType;
Members
- head
- The element header.
- cutPlShow
- Stories to show cutplane on.
- storyToShowOn
- Story to show cutplane on, if cutPlShow is
APICutPl_ShowOnOneStory
. - segment
- Used to get and set the defaults; real segments are in the memo.
- useCommonMarker
- Show the common marker.
- markerGuid
- Guid of the common marker object.
- markerPen
- Pen of the common marker.
- markerFont
- Font of the common marker.
- markerSize
- Size of the common marker.
- markerTextSize
- Size of the common marker’s text.
- nSegments
- Number of segments in the memo.
- nLineCoords
- Total number of segment line coordinates.
- poly
- Polyline of the connected segments.
Remarks
This structure represents an interior elevation element. The section segment information is stored in the element memo.
Requirements
- Version: API 11 or later
- Header: APIdefs_Elements.h
See Also
API_Elem_Head, API_CutPlaneShowType, API_SectionSegment, API_Polygon, API_ElementMemo, API Types