API_​InternalAnalyticalMemberPartId

Describes a Structural Analytical Model Analytical Member part.

    class API_InternalAnalyticalMemberPartId {
    public:
        UInt32   contourIdx;
        UInt32   edgeOrVertexIdx;
        UInt32   edgeFragmentIndex;
    };

 

Members

contourIdx 24
Identifies the contour (needs to be 0 in case of curve members).
edgeOrVertexIdx 24
Identifies the edge (needs to be 0 in case of curve members).
edgeFragmentIndex 24
Identifies the fragment of the edge (needs to be 0 in case of curve members).

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalElements.h

 

See Also

API Types