Describes the file to work on in your callback procedure.
typedef struct { short refCon; short method; UInt32 fileTypeID; IO::Location *fileLoc; IO::Location *fileLocOnServer; IO::Name *saveFileIOName; bool noDialog; bool fromDragDrop; bool filler_1 [6]; API_Vector dropOffset; GSPtr additionalData; Int32 filler_2; API_Guid drawingGuid; Int32 filler_3 [6]; } API_IOParams;
Members
- refCon
- The identifier of your file type. It’s is the same what you called ACAPI_Install_FileTypeHandler with, and also the same what you used in the ACAPI_Register_FileType as a reference number in the RegisterInterface function.
- method
-
Tells the type of operation your add-on was called to perform; basically identifies the dialog. Its value can be one of the followings:
IO_OPEN
IO_MERGE
IO_OPENLIBPART
IO_SAVEAS
IO_SAVEAS3D
IO_SAVEASFLY3D
IO_IMPORT
- fileTypeID
- The file type registered with the internal File Type Manager.
- fileLoc
- The location of the file in the file system.
- fileLocOnServer
- Contains the BIMcloud location of the file without authentication info if the file was originally downloaded from BIMcloud. Only set for Save and Merge operations.
nullptr
otherwise. - saveFileIOName
- Contains the Unicode name of the file entered into the Save dialog (in this case
fileLoc
refers to a scratch file). - noDialog
- Work in silent mode (for normal drag & drop operations its default value is
true
).
- fromDragDrop
- Indicates whether a merge operation (
IO_MERGE
method) was initiated via drag & drop. In this case thedropOffset
field contains the dropping coordinates. - dropOffset
- At a drag & drop merge this field contains the drop position relative to project origin; in all the other cases it is null vector.
- additionalData
- Reserved for internal use.
- drawingGuid
- GUID of the drawing element during relink.
Remarks
This structure is used as the parameter of the APIIOCommandProc callback function for identifying the file you should work on.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Callback.h
See Also
APIIOCommandProc
ACAPI_Install_FileTypeHandler
ACAPI_Register_FileType
API Types