API_​KeyType

Description of a key.

    typedef struct {
        API_ListData_Head     head;
        char                  code[API_DBCodeLen];
        char                  name[API_DBNameLen];
        Int32                 filler_1[8];
    } API_KeyType;

 

Members

head
Contains the header information, including type, setIndex and index.
code
code string, this member is is the same as the keycode member of the API_Obsolete_ComponentType and API_DescriptorType structures.
name
name of the key

 

Remarks

This structure is used when you get or search a key in the listing database. See the ACAPI_ListData_Get and ACAPI_ListData_Search functions.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_ListData.h

 

See Also

API_ListData_Head, API_ListData,
Listing Manager, API Types