Layer combination attribute representation.
typedef struct { API_Attr_Head head; Int32 lNumb; bool inEffect; bool filler_1; short filler_2; } API_LayerCombType;
Members
- head
- Contains the name and the index of the layer combination.
- lNumb
- The number of layers in this combination.
- inEffect
- The layers currently are set according to this layer combination.
Remarks
The layer combination attribute contains all the visibility and locking information for each layer. This also means that the number of layers (the lNumb field) has the same value in all layer combinations. When you create a new layer, it will appear in all layer combinations as unlocked and visible.
There are additional data assigned to the layer combination attributes in the API_AttributeDef structure; the status information to each layer is passed through the layer_statItems
field. Refer to the API_LayerStat structure to get more details on it.
Requirements
- Version: API 1.3 or later
- Header: APIdefs_Attributes.h
See Also
API_Attr_Head
API_Attribute
API_LayerStat
API_AttributeDef
APIEnv_GetCurrLayerCombID
APIEnv_ChangeCurrLayerCombID
Attribute Manager
API Types