API_​LayerStat

Describes the visibility and lock status of every layer in a layer set.

    typedef struct {
        API_AttributeIndex lInd;
        short              lFlags;
        short              filler_1;
        Int32              conClassId;
        Int32              filler_2;
    } API_LayerStat;

 

Members

lInd
The index of the layer attribute (1..n, where n is the number of layers).
lFlags
The status (hidden/visible, locked/open) of the layer. The values are the same as for the flags in the header of API_LayerType.
conClassId
The connection class of the layer; elements on layers having the same class will be intersected. 4.3

 

Remarks

Each layer set contains the individual settings for all layers; these settings are stored in an array of this structure.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_Environment.h

 

See Also

API_LayerCombType, API_AttributeIndex
API_AttributeDef
API Types