API_​LayerType

Layer attribute representation.

    typedef struct {
        API_Attr_Head     head;
        Int32             conClassId;
        Int32             filler_1;
    } API_LayerType;

 

Members

head
Specifies the name, index, and flags of the layer attribute.
conClassId
The connection class of the layer; elements on layers having the same class will be intersected.

 

Remarks

The flags field of the header can take the following values:

Value

Description

APILay_Hidden

The layer is hidden.

APILay_Locked

The layer is locked.

APILay_NotMine

The layer is not mine.

APILay_ForceToWire

The elements on the layer are shown in wireframe mode in the corresponding Layer Combination. 4.3

APILay_Xref

The layer is coming from an XREF-ed (DWG or DXF) drawing. These layers are grouped in the Layer Settings dialog. Featuring API 11

Layers work the same way as if you would use Archicad from the user interface. This means you cannot create elements on a locked or hidden layer. This is especially important if you write an I/O type Add-On, as in this case you need to create elements on visible layers, and then modify the visibility of the layers.

There is no additional data assigned to layer attributes in the API_AttributeDef structure.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_Attributes.h

 

See Also

API_Attr_Head
API_Attribute
Attribute Manager
API Types