API_​LayoutsPrefs

The representation of the Layouts page of the Project Preferences.

    typedef struct {
        API_RGBColor     masterColor;
        bool             useOwnMasterColor;
        bool             adjustDrawingFrameToViewZoom;
        char             filler[6];
    } API_LayoutsPrefs;

 

Members

masterColor
Color of master items on the layout.
useOwnMasterColor
Use master items’ own color.
adjustDrawingFrameToViewZoom
When placing model views onto layouts, adjust each drawing frame to show only zoomed area of model view.

 

Remarks

This structure is used by the APIEnv_GetPreferencesID function to get the settings of the Layouts preferences page.

 

Requirements

Version: API 10 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetPreferencesID
API Types