The representation of the linear, radial, level, elevation, door/window and parapet dimensioning on the Preferences / Dimensioning tab page.
typedef struct { API_LengthTypeID unit; short filler_0; short roundInch; short lenDecimals; bool show0Whole; char show0Inch; API_ExtraAccuracyID showSmall5; bool hide0Dec; char filler_1; short filler_2; } API_LengthDimFormat;
Members
- unit
- measurement unit, for the possible values see API_LengthTypeID
- roundInch
- fractional inches (1, 2, 4, 8, 16, 32, 64)
- lenDecimals
- number of decimals (0, 1, 2, 3, 4)
- show0Whole
- show zeros to the left of the decimal point
- show0Inch
- show zeros to the left of the decimal inches
- showSmall5
- European methods for rounding decimal values
- hide0Dec
- hide zeros at the right of the decimal point
Remarks
This structure is a member of API_DimensionPrefs.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Environment.h
See Also
API_DimensionPrefs
API_ExtraAccuracyID
API_AngleDimFormat
API_AreaDimFormat
APIEnv_GetPreferencesID
API Types