API_​LghtSouID

Possible types of a 3D light source.

    typedef enum {
        APILght_DistantID,
        APILght_DirectionID,
        APILght_SpotID,
        APILght_PointID,
        APILght_SunID,
        APILght_EyeID
    } API_LghtSouID;

 

Members

APILght_DistantID
distant light
APILght_DirectionID
directional light
APILght_SpotID
spot light
APILght_PointID
radiates light in every direction
APILght_SunID
parallel light

 

Remarks

These identifiers are usable in API_LghtType type field.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_3D.h

 

See Also

API_LghtType, API Types