Detail parameters of a Library Part.
typedef union { struct { bool fixSize; bool autoHotspot; bool uiTabDefault; bool sizeTo2D; bool uiUseHierarchicalPages; bool runVLScriptOnlyOnce; bool enableHideFixNamedParams; bool enable2DScriptDrawingOrder; Int32 filler_2[6]; } object, light, label, zone; struct { char mirThickExpr[512]; char wallInsetExpr[512]; char leftFramExpr[512]; char righFramExpr[512]; char topFramExpr[512]; char botFramExpr[512]; float mirThick; float wallInset; float leftFram; float righFram; float topFram; float botFram; char orientation; char filler_3; bool contours_3D; bool uiTabDefault; bool uiUseHierarchicalPages; bool runVLScriptOnlyOnce; bool enable2DScriptDrawingOrder; char filler_1[1]; char defaultLabel[32]; char mirroredLabel[32]; Int32 filler_2[8]; } wind, door; } API_LibPartDetails;
Members
- fixSize
- Store fix values rather than the ratio of current/default A/B sizes
- autoHotspot
- Place hotspots on the bounding box
- uiTabDefault
- Open the dialog with the User Interface tab page as the default
- sizeTo2D
- Adjust parameters A and B to the bounding box of the 2D symbol
- uiUseHierarchicalPages
- Use the new hierarchycal UI page system in object settings dialog
- runVLScriptOnlyOnce
- Run the parameter script of the library only once.
- enable2DScriptDrawingOrder
- Drawing order follows order of commands in 2D Script.
- mirThickExpr
- Window/door draw mirror thickness expression
- wallInsetExpr
- Window/door parapet wall inset expression
- leftFramExpr
- Window/door left frame expression
- righFramExpr
- Window/door right frame expression
- topFramExpr
- Window/door top frame expression
- botFramExpr
- Window/door bottom frame expression
- mirThick
- Window/door draw mirror thickness if not expression
- wallInset
- Window/door parapet wall inset if not expression
- leftFram
- Window/door left frame if not expression
- righFram
- Window/door right frame if not expression
- topFram
- Window/door top frame if not expression
- botFram
- Window/door bottom frame if not expression
- orientation
-
Defines the way the opening’s orientation is displayed:
API_Orient_Default
Display Door/Window opening orientation as a standard default setting API_Orient_Reverse
Display Door/Window opening orientation in reverse as a standard default setting API_Orient_Custom
Use customized display of Door/Window opening orientation - contours_3D
- 3D image is framed (wind/door)
- uiTabDefault
- Open the dialog with the User Interface tab page as the default.
- uiUseHierarchicalPages
- Use the new hierarchycal UI page system in object settings dialog
- runVLScriptOnlyOnce
- Run the parameter script of the library only once.
- enable2DScriptDrawingOrder
- Drawing order follows order of commands in 2D Script.
- defaultLabel
- Default position label
- mirroredLabel
- Mirrored position label
Remarks
This structure contains the detail parameters of the library part. These parameters can be edited in Archicad by clicking the Details button on the parameter list editor dialog box.
Note, that the parameters depend on the type of the Library Part. These parameters are coded in the parameter section (API_SectParamDef
) of the Library Part.
Refer to the ACAPI_LibPart_GetDetails and ACAPI_LibPart_SetDetails_ParamDef functions to get or modify such parameters of a Library Part.
In Archicad 10 the
contours_2D
field has been removed from the structure.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_LibraryParts.h
See Also
ACAPI_LibPart_GetDetails, ACAPI_LibPart_SetDetails_ParamDef, API Types