API_​LibPartSection

Definition of a Library Part section.

    typedef struct {
        GSType             sectType;
        unsigned short     subIdent;
        short              version;
        Int32              filler_2;
    } API_LibPartSection;

 

Members

sectType
Section type
subIdent 13
Section secondary identifier. Became unsigned short in v13.
version
Version of section data (not used for custom sections)

 

Remarks

A Library Part is composed of several sections. Each section has an owner, a signature versioning information and data bytes. This data structure is designed to hold the available section headers.

The built in section types (that can be interpreted by Archicad) are:

Section type (API 1.3 or later)

 

API_SectParamDef

Parameter section type

API_Sect1DScript

1D script section type

API_Sect2DDraw

2D binary (draw) section type

API_Sect2DScript

2D script section type

API_Sect3DScript

3D script section type

API_SectPRScript

Properties script section type

API_SectUIScript

User Interface script section type

API_SectVLScript

Value List script section type

API_Sect3DBinData

3D binary section type

API_SectPropData

Properties section type

API_SectComText

Comment text section type

API_SectInfoPict

Info picture section type (PICT format)

API_SectInfoGIF

Info picture section type (GIF format)

 

 

Section type (API 2.1 or later)

 

API_SectGDLPict

Pictures referenced from the GDL (GIF format)

API_SectSubKind

Symbol SubKind data section type

API_SectCompDef

Component section type

API_SectDescDef

Descriptor section type

 

 

Section type (API 4.1 or later)

 

API_SectCalledMacros

Called macros section type

API_SectAncestors

Ancestor for subtyping

 

 

Section type (API 15 or later)

 

API_SectFWMScript

Forward migration script section type

API_SectBWMScript

Backward migration script section type

API_SectMigrTable

Migration table section type

 

 

Section type (API 16 or later)

 

API_SectLibPartURL

BIMcomponents.com URL

API_SectCopyright

Copyright information for BIMcomponents.com elements

API_SectKeywords

Lists keywords for searching

If the sectType field (a four-character case-sensitive identifier) does not match any types listed above, it is interpreted as a custom type. In this case the owner application is responsible for the content and the management of the section data.

This structure is used by many Library Part Manager functions as a parameter.

More detailed information on the standard Library Part sections can be found in the Archicad Reference Manual.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_LibraryParts.h

 

See Also

Library Part Manager, API Types