Project library types.
typedef enum { API_Undefined, API_LocalLibrary, API_UrlLibrary, API_BuiltInLibrary, API_EmbeddedLibrary, API_OtherObject, API_UrlOtherObject, API_ServerLibrary } API_LibraryTypeID;
Remarks
The libraryType
data member in the API_LibraryInfo structure defines the type of the project library, which can be
- Local Library
- Embedded Library
- Built-In Library
- Library on a BIMcloud / BIM Server
- Web Objects (addressed by URL)
- Other local objects
Requirements
- Version: API 20 or later
- Header: APIdefs_Environment.h