API_​LibTypeID

Library Part types.
From Archicad 8 these categories are obsolete due to the introduction of library part subtypes.

    typedef enum {
        API_ZombieLibID     = 0,
        APILib_SpecID       = 1,
        APILib_WindowID     = 2,
        APILib_DoorID       = 3,
        APILib_ObjectID     = 4,
        APILib_LampID       = 5,
        APILib_RoomID       = 6,
        APILib_PropertyID   = 7,
        APILib_PlanSignID   = 8,
        APILib_LabelID      = 9,
        APILib_MacroID      = 10,
        APILib_PictID       = 11,
        APILib_ListSchemeID = 12,
        APILib_SkylightID   = 13
    } API_LibTypeID;

 

Remarks

The values correspond to a given type of Library Part.

Generally this value is referenced from the API_LibPart structure.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_LibraryParts.h

 

See Also

API_LibPart,
LibPart Manager, API Types