API_​LineItems

Describes the details of a symbol line.

    typedef struct {
        API_LtypItemID     itemType;
        Int32              filler_1;
        double             itemCenterOffs;
        double             itemLength;
        API_Coord          itemBegPos;
        API_Coord          itemEndPos;
        double             itemRadius;
        double             itemBegAngle;
        double             itemEndAngle;
    } API_LineItems;

 

Members

itemType
The symbol line item type.
itemCenterOffs
The vertical distance from the origin of the symbol line. Used in separator, centerdot, and centerline item types.
itemLength
The length of the item, measured along the length of the item. Used in centerline, rightangle, and parallel item types.
itemBegPos
The beginning position of an item. Used in dot, rightangle, parallel, line, circle, and arc item types.
itemEndPos
The end position of an item. Used in line item type.
itemRadius
The radius of an item. Used in circle and arc item types.
itemBegAngle
The beginning angle of an item, measured from the vertical (!) axis. Used in arc item type.
itemEndAngle
The end angle of an item, measured from the vertical (!) axis. Used in arc item type.

 

Remarks

A detailed example can be found in the APIBases example of the Development Kit.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_Attributes.h

 

See Also

API_LtypItemID, API_Coord, API_LinetypeType, API_AttributeDef,
API Types