API_​LinkToSettings

Option for linking model elements to their home stories.

    typedef struct {
        short     homeStoryDifference;
        bool      newCreationMode;
        bool      filler_1;
    } API_LinkToSettings;

 

Members

homeStoryDifference
Difference of home story from current story.
newCreationMode
Use this structure during element creation. If it is true, then head.floorInd will not be taken into account, otherwise homeStoryDifference will be filled.

 

Remarks

Automatic link type can set only for API_BeamType, API_ColumnType, API_ShellBaseType, API_MorphType and API_WallType elements. API_MeshType, API_LampType, API_ObjectType and API_SlabType contain the same structure but this feature was not extended for these elements.

 

Requirements

Version: API 11 or later
Header: APIdefs_Elements.h

 

See Also

API_BeamType, API_ColumnType, API_LampType, API_MeshType
API_ObjectType, API_SlabType, API_ShellBaseType, API_WallType, API_MorphType
API Types