The representation of a listdata.
typedef union { API_ListData_Head header; API_KeyType key; API_UnitType unit; API_Obsolete_ComponentType component; API_DescriptorType descriptor; } API_ListData;
Members
- header
- A common header for all the listdata types. It contains information which applies to all the listdata types.
- key
- a key listdata
- unit
- an unit listdata
- component
- a component listdata
- descriptor
- a descriptor listdata
Remarks
This union is used when you get or search in the listing database. See the ACAPI_ListData_Get, ACAPI_ListData_GetLocal, ACAPI_ListData_Search functions.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_ListData.h
See Also
API_ListData_Head,
API_KeyType, API_UnitType, API_Obsolete_ComponentType, API_DescriptorType,
Listing Manager, API Types