Contains common information related to all listing component types.
typedef struct { API_ListDataID typeID; Int32 setIndex; Int32 index; Int32 filler_1; } API_ListData_Head;
Members
- typeID
- type of the listdata
- setIndex
- index of the set the component is in
- index
- index of the listdata in the set
Remarks
This structure contains general information about a listdata. See the ACAPI_ListData_Get, ACAPI_ListData_GetLocal, ACAPI_ListData_Search functions.
Below you can find the types of the list data:
Description
API_ZombieListDataID
A dummy value (
0
).
API_KeyID
Denotes a key listdata.
API_UnitID
Denotes an unit listdata.
API_Obsolete_ComponentID
Denotes a component listdata.
API_DescriptorID
Denotes a descriptor listdata.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_ListData.h