Representation of a listdata set.
typedef struct { Int32 setIndex; Int32 compLibInd; Int32 descLibInd; Int32 unitLibInd; Int32 keyLibInd; Int32 critLibInd; Int32 listSetupLibInd; Int32 filler_1; char setName[API_NameLen]; Int32 filler_2[16]; } API_ListDataSetType;
Members
- setIndex
- index of the set of the listing database
- compLibInd
- index of components library part
- descLibInd
- index of the descriptors library part
- unitLibInd
- index of the units library part
- keyLibInd
- index of the keys library part
- critLibInd
- index of the criteria’s library part
- listSetupLibInd
- index of the list setup library part
- setName
- name of the set
Remarks
This structure is used when you get information about a set of the listing database. See the ACAPI_ListData_GetSet function.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_ListData.h