API_​LtypItemID

Describes the various item types of a symbol line.

    typedef enum {
        APILine_IllegalItemType,
        APILine_SeparatorItemType,
        APILine_CenterDotItemType,
        APILine_CenterLineItemType,
        APILine_DotItemType,
        APILine_RightAngleItemType,
        APILine_ParallelItemType,
        APILine_LineItemType,
        APILine_CircItemType,
        APILine_ArcItemType
    } API_LtypItemID;

 

Members

APILine_IllegalItemType
Dummy (illegeal) item type.
APILine_SeparatorItemType
Separator line item type. It is described with a center offset (vertical distance from the origin).
APILine_CenterDotItemType
Center dotted line item type (a horizontal row of dots going through the vertical center). It is described with a center offset (vertical distance from the origin).
APILine_CenterLineItemType
Center line item type (a horizontal solid line going through the vertical center).It is described with a center offset (vertical distance from the origin) and its length.
APILine_DotItemType
Dotted line item type (a horizontal row of dots). It is described by its beginning position.
APILine_RightAngleItemType
A solid vertical line item, described by its beginning position and length.
APILine_ParallelItemType
A solid line item, parallel with the horizontal direction. It is described by its beginning position and length.
APILine_LineItemType
A solid line item, described by its beginning and end position.
APILine_CircItemType
A circle item, described by its beginning position (the center) and radius.
APILine_ArcItemType
An arc item, described by its beginning position (the center), its radius, its beginning and end angle.

 

Remarks

These are the item types you can use to describe a symbol line.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_Attributes.h

 

See Also

API Types