Curve tracing parameters.
typedef struct { short divArcMode; short traceMethod; short filler_1; short arcSegNumb; double arcDiff; double partLength; Int32 filler_2[8]; } API_MagicWandInfo;
Members
- divArcMode
- Mode of the approximating curves with linear segments. Possible values are:
API_ArcDiv_DivArc
,API_ArcDiv_DivCircle
,API_ArcDiv_DiffArc
,API_ArcDiv_PartLength
,API_ArcDiv_DivArc
- traceMethod
- Trace method mode. Possible values are:
API_ArcTrace_Linear
,API_ArcTrace_BestMatch
- arcSegNumb
- The deviation from curves less than
- arcDiff
- Number of the segment along arc/circles
- partLength
- Segment length
Remarks
This structure corresponds to the “Magic Wand Settings…” dialog of Archicad. Follow the actual settings in the case yo need to trace curves with linear segments.
Refer to the APIEnv_GetMagicWandSetsID function to get the current settings.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Environment.h