API_​MarkUpCommentType

Represents a comment attached to a Mark-Up entry.

    typedef struct {
        API_Guid                      guid;
        GS::UniString                 author;
        GS::UniString                 text;
        API_MarkUpCommentStatusID     status;
        GSTime                        creaTime;
        Int32                         filler_1[2];
    } API_MarkUpCommentType;

 

Members

guid
Identifier of the comment
author
The author of the comment
text
Text of the comment
status
Status. See API_MarkUpCommentStatusID for further info.
creaTime
Creation time

 

Remarks

Comment can be added with ACAPI_MarkUp_AddComment function to an existing Mark-Up entry and the list of the comments can be retrieved using ACAPI_MarkUp_GetComments.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_MarkUpType
ACAPI_MarkUp_GetComments, ACAPI_MarkUp_AddComment
API Types