Describes the type of a component attached to a Mark-Up entry.
typedef enum { APIMarkUpComponent_Creation = 0, APIMarkUpComponent_Highlight, APIMarkUpComponent_Deletion, APIMarkUpComponent_Modification } API_MarkUpComponentTypeID;
Members
- APIMarkUpComponent_Creation
- Creation (previously it was named correction)
- APIMarkUpComponent_Highlight
- Highlight
- APIMarkUpComponent_Deletion
- Deletion
- APIMarkUpComponent_Modification
- Modification
Remarks
ACAPI_MarkUp_AttachElements and ACAPI_MarkUp_GetAttachedElements functions use this enum.
Requirements
- Version: API 26 or later
- Header: APIdefs_Elements.h
See Also
ACAPI_MarkUp_AttachElements, ACAPI_MarkUp_GetAttachedElements
API Types