API_​MarkUpType

Represents a Mark-Up entry.

    typedef struct {
        API_Guid           guid;
        GS::UniString      name;
        API_Guid           parentGuid;
        Int32              filler_0;
        short              filler_1;
        short              filler_2;
        GSTime             creaTime;
        GSTime             modiTime;
        GS::UniString      tagText;
        API_Guid           tagTextElemGuid;
        bool               isTagTextElemVisible;
        bool               filler_3[7];
    } API_MarkUpType;

 

Members

guid
Identifier of the Mark-Up
name
Name
parentGuid
The identifier of the parent Mark-Up
creaTime
Creation time
modiTime
Modification time
tagText
Tag text
tagTextElemGuid
The identifier of the attached tag text element
isTagTextElemVisible
The visibility of the attached tag text element

 

Remarks

Use ACAPI_MarkUp_Create function to create and ACAPI_MarkUp_Delete function to delete Mark-Up entry. Mark-Ups can be listed with ACAPI_MarkUp_GetList function.
Elements can be attached to the Mark-Up using ACAPI_MarkUp_AttachElements and comment can be added with ACAPI_MarkUp_AddComment function.

 

Requirements

Version: API 23 or later
Header: APIdefs_Elements.h

 

See Also

API_MarkUpCommentType
ACAPI_MarkUp_GetList, ACAPI_MarkUp_Create
API Types