API_​MDCLParameter

Parameter structure used for inter-addon communication.

    typedef struct {
        Int32          index;
        const char     *name;
        Int32          type;
        bool           modified;
        bool           filler_1[3];
        union {
            Int32          int_par;
            void           *ptr_par;
        };
        double         float_par;
        const char     *string_par;
    } API_MDCLParameter;

 

Members

index
Parameter index (used only with APIAny_GetMDCLParameterID)
name
Pointer to the name of the parameter
type
Type of the parameter. Can be one of the following constants:
  • MDCLPar_string – string type parameter
  • MDCLPar_int – integer type parameter
  • MDCLPar_float – floating point number type parameter
modified
The parameter was modified with the APIAny_ChangeMDCLParameterID function
int_par
Integer or pointer parameter value (valid only if type is MDCLPar_int)
ptr_par 13
Pointer parameter value (valid only if type is MDCLPar_ptr). Note that on 64-bit the size of pointers is 8 bytes.
float_par
Floating point parameter value (valid only if type is MDCLPar_float)
string_par
String parameter value (valid only if type is MDCLPar_string). Note that on 64-bit the size of pointers is 8 bytes.

 

Remarks

This structure is used for parameter passing in inter-addon communications.
For further information refer to the Communication Manager.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Goodies.h

 

See Also

Communication Manager
APIAny_AddMDCLParameterID
APIAny_ChangeMDCLParameterID
APIAny_GetMDCLParameterID
API Types