ModulData operation code.
typedef enum { APIMDSetMerge_TW = 11,, APIMDSetMerge_HLM = 12,, APIMDSetMerge_Merge = 13 } API_MDSetCmd;
Remarks
This value is passed as a parameter to the APIModulDataMergeHandlerProc callback function.
When the ModulData Manager notifies your add-on, this code tells you the type of operation your add-on is called for.
The APIMDSetMerge_Merge
code means that the notification is posted because of the database must be updated; invoked by the Merge or Copy commands.
The APIMDSetMerge_HLM
and APIMDSetMerge_TW
means the notification is posted because of the databases must be merged; invoked by Teamwork (Send Changes, Receive Changes), or Place Hotlink Module commands, respectively.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_ModulData.h