API_​MenuParams

Describes the menu item that was chosen.

    typedef struct {
        API_MenuItemRef        menuItemRef;
    } API_MenuParams;

 

Members

menuItemRef
The menu item chosen by the user. The menuItemRef.menuResID is the same what you called ACAPI_Install_MenuHandler with, and also the same what you used in the ACAPI_Register_Menu as a menu number in the RegisterInterface function.

 

Remarks

This is the parameter of the APIMenuCommandProc callback function, identifying the menu item your add-on was called for.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Callback.h

 

See Also

ACAPI_Install_MenuHandler
ACAPI_Register_Menu
RegisterInterface
API_MenuItemRef
API Types