API_​MEPSystemType

MEP System attribute representation.

    typedef struct {
        API_Attr_Head      head;
        bool               isForDuctwork;
        bool               isForPipework;
        bool               isForCabling;
        bool               filler_1;
        short              contourPen;
        short              fillPen;
        short              fillBgPen;
        short              centerLinePen;
        API_AttributeIndex fillInd;
        API_AttributeIndex centerLTypeInd;
        API_AttributeIndex materialInd;
        API_AttributeIndex insulationMatInd;
        Int32              filler_2;
    } API_MEPSystemType;

 

Members

head
Specifies the index and the name of the MEP System.
isForDuctwork
MEP System available for ductwork.
isForPipework
MEP System available for pipework.
isForCabling
MEP System available for cabling.
contourPen
The index of the contour pen [1..255].
fillPen
The index of the fill pen [1..255].
fillBgPen
Index of the background pen [0..255]. The special 0 value means transparent background.
centerLinePen
The index of the center line pen [1..255].
fillInd
The index of the fill pattern attribute (1..n, where n is the number of simple fill attributes).
centerLTypeInd
The index of the center line attribute (1..n, where n is the number of simple line attributes).
materialInd
The index of the material attribute (1..n, where n is the number of simple material attributes).
insulationMatInd
The index of the insulation material attribute (1..n, where n is the number of simple material attributes).

 

Remarks

One MEP System always exists, i.e. you cannot delete the last MEP System attribute.

There is no additional data assigned to MEP System attributes in the API_AttributeDef structure.

 

Requirements

Version: API 13 or later
Header: APIdefs_Attributes.h

 

See Also

API_Attr_Head, API_Attribute, API_AttributeIndex,
Attribute Manager, API Types