API_​MeshLevel

Defines the level lines of a mesh.

    typedef struct {
        Int32     nCoords;
        Int32     nSubLines;
    } API_MeshLevel;

 

Members

nCoords
Number of vertices in the level lines.
nSubLines
Number of sublines including the first one.

 

Remarks

This structure should be used in conjunction with the meshLevelCoords and meshLevelEnds fields of API_ElementMemo. The meshLevelCoords field defines the coordinates of the level line points; while meshLevelEnds field contains the indices of the end points of each level line in the meshLevelCoords array.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_MeshType, API_ElementMemo, API_MeshLevelCoord, API Types