API_​MeshQuantity

Describes the different calculated values for meshes.

    typedef struct {
        double     bottomSurface;
        double     topSurface;
        double     edgeSurface;
        double     volume;
        double     perimeter;
        double     holesSurf;
        double     holesPrm;
        double     projectedArea;
        double     filler_1[8];
    } API_MeshQuantity;

 

Members

bottomSurface
bottom surface of the mesh
topSurface
top surface of the mesh
edgeSurface
surface of the edge of the mesh
volume
volume of the mesh
perimeter
perimeter of the mesh
holesSurf
total area of holes in the mesh
holesPrm
total perimeter of holes in the mesh
projectedArea19
projected area of the mesh

 

Remarks

See also the mesh parameters for listing in Appendix A of the GDL Reference manual.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types