API_​MeshType

Represents a mesh.

    typedef struct {
        API_Elem_Head               head;
        short                       contPen;
        short                       levelPen;
        API_AttributeIndex          ltypeInd;
        API_AttributeIndex          buildingMaterial;
        short                       filler_1[2];
        API_PenOverrideType         penOverride;
        short                       sectContPen;
        API_OverriddenAttribute     topMat;
        API_OverriddenAttribute     sideMat;
        API_OverriddenAttribute     botMat;
        bool                        materialsChained;
        bool                        filler_2;
        bool                        useFloorFill;
        char                        smoothRidges;
        short                       showLines;
        short                       skirt;
        short                       filler_3[2];
        double                      level;
        double                      skirtLevel;
        char                        filler_4[16];
        API_StoryVisibility         visibilityCont;
        API_StoryVisibility         visibilityFill;
        API_LinkToSettings          linkToSettings;
        short                       floorFillPen;
        short                       floorFillBGPen;
        API_AttributeIndex          floorFillInd;
        bool                        useLocalOrigo;
        bool                        use3DHatching;
        short                       filler_5;
        API_Polygon                 poly;
        Int32                       filler_6;
        API_MeshLevel               levelLines;
        API_Coord                   locOrigo;
        double                      fillAngle;
        Int32                       filler_7[2];
        bool                        filler_8[8];
    } API_MeshType;

 

Members

head
General element header.
contPen
Pen attribute index of the mesh’s contour.
levelPen
Pen attribute index of the mesh’s level lines.
ltypeInd
Line type attribute index of mesh’s contour.
buildingMaterial Featuring API 17
Building Material index of mesh’s hatch.
penOverride Featuring API 17
Cut fill pens set in the building material can be overridden on the element level.
sectContPen
Contour pen attribute index of the mesh ‘s fill in sections.
topMat Featuring API 17
Top material attribute override structure.
sideMat Featuring API 17
Side material attribute override structure.
botMat Featuring API 17
Bottom material attribute override structure.
useFloorFill 6.1
Use cover fill?
materialsChained 20
Are surface materials chained?
smoothRidges
How the connecting surfaces to be shown in the PhotoRendering window:

APIRidge_AllSharp

All ridges sharp

APIRidge_AllSmooth

All ridges smooth

APIRidge_UserSharp

Only the user defined ridges are sharp 4.3

showLines
False: hide secondary lines; true: show everything.
skirt
Skirt: 1 = yes; 2 = no bottom; 3 = no.
level
Height of base plane of the mesh from the floor level.
skirtLevel
Distance of the mesh’s bottom from the base plane of the mesh.
visibilityCont 6.1
Visibility of mesh’s contour line. On the element’s own story the contour should allways be visible.
visibilityFill 6.1
Visibility of mesh’s cover fill.
linkToSettings Featuring API 11
Mode of linking to home story.
floorFillPen 6.1
Pen attribute index of mesh’s cover fill.
floorFillBGPen 6.1
Background pen attribute index of the mesh’s cover fill.
floorFillInd 6.1
Fill attribute index of the mesh’s cover fill.
useLocalOrigo 6.1
Use local origo for cover fill drawing?
use3DHatching 6.1
Reserved for internal use.
poly
The polygon of the mesh.
levelLines
The level lines of the mesh.
locOrigo 6.1
Base coordinate of mesh’s cover fill reference vector if it’s linked to the element.
fillAngle 6.1
Angle of mesh’s cover fill reference vector if it’s linked to the element.

 

Remarks

Featuring API 17  In Archicad 17 the the elements’ cut fill foreground and background pens inherit from the building material, and can be overridden on the element level.

Featuring API 17  In Archicad 17 the the elements’ surface materials inherit from the building material, and can be overridden on the element level.

For morph related memo data see the ACAPI_Element_GetMemo function.

For mesh related memo data see the ACAPI_Element_GetMemo function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_Elem_Head, API_Element,
API_Polygon, API_MeshLevel, API_StoryVisibility, API_LinkToSettings, API_ElementMemo,
Element Manager, API Types