API_​MimePicture

Structure for picture conversion using MIME identifier.

    typedef struct {
        const char           *mimeIn;
        GSHandle             inputHdl;
        const char           *mimeOut;
        GSHandle             outputHdl;
        bool                 inContainsMime;
        bool                 filler_0 [3];
        API_ColorDepthID     outDepth;
        Int32                filler_1 [4];
    } API_MimePicture;

 

Members

mimeIn
MIME type of the image to be converted (nullptr-terminated C string)
inputHdl
contains the input image handle
mimeOut
the requested MIME type of the output image (nullptr-terminated C string)
outputHdl
on return contains the output image
inContainsMime
for library part preview pictures, where the handle starts with a MIME type
outDepth
the requested output pixel depth (APIColorDepth_FromSourceImage) means to use the same pixel depth the input image has)

 

Remarks

This structure is used as a parameter of the APIAny_ConvertMimePictureID goody function to convert a picture from a given format into another using MIME types.

You can also set these special formats in the mimeOut field:

  • on Windows "vnd/DIB" results outputHdl containing a device independent bitmap

In some cases the image handle contains the MIME type as well. For example pictures in Library Parts are stored in a handle that begins with the ‘\0’-terminated MIME type string, and then follows the image itself. If inputHdl has this format, set the inContainsMime field true. In this case the mimeIn parameter is ignored.

 

Requirements

Version: API 5.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_PictureFormat
API_ColorDepthID
APIAny_ConvertMimePictureID
APIAny_ConvertPictureID
API Types