Miscellaneous information of the selected printer
typedef struct { char name [256]; bool orientPortrait; char filler [7]; } API_MiscPrinterInfo;
Members
- name
- Name of selected printer.
- orientPortrait
- Currently selected orientation: portrait (true) or landscape (false).
Remarks
This structure contains name and orientation of selected printer in Archicad.
Call the ACAPI_Environment function with the APIEnv_GetMiscPrinterInfoID function code to get this data.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Environment.h