API_​ModelElemStructureType

Determines the structure type of the element.

    typedef enum {
        API_BasicStructure,
        API_CompositeStructure,
        API_ProfileStructure
    } API_ModelElemStructureType;

 

Members

API_BasicStructure
The structure is defined by a Building Material attribute.
API_CompositeStructure
The structure is defined by a Composite attribute.
API_ProfileStructure
The structure is defined by a Profile attribute.

 

Remarks

Valid structure types of an element type are shown in the table below:

Element Type Basic Structure Composite Structure Profile Structure
API_WallID x x x
API_ColumnID, API_BeamID x x
API_SlabID, API_RoofID, API_ShellID x x

API_MeshType, API_MorphType and API_CurtainWallType always contain Building Material, so they don’t have this structure.

 

Requirements

Version: API 17 or later
Header: APIdefs_Elements.h