API_​ModelViewOptions

Represents the model view options.

    typedef struct {
        char                                filler_0[2];
        char                                doorMode;
        char                                windowMode;
        char                                skylightMode;
        char                                filler_1;
        char                                sectionMarker;
        char                                beamMethod;
        char                                roofShellMode;
        char                                showColumnSymbol;
        char                                slabMethod;
        char                                filler_2;
        bool                                coluHiddenlineUnderSlabs;
        bool                                beamHiddenlineUnderSlabs;
        bool                                showMarkupItems;
        bool                                zoneHideZoneStamp;
        API_CurtainWallModelViewOptions     curtainWallModelViewOptions;
        API_StairModelViewOptions           stairModelViewOptions;
        API_RailingModelViewOptions         railingModelViewOptions;
        API_GDLModelViewOptions             *gdlOptions;
    } API_ModelViewOptions;

 

Members

doorMode 10
Door display definition.
Possible values: API_Hole_ShowWithDim, API_Hole_ShowOnPlan, API_Hole_HideOnPlan, API_Hole_ReflCeiling, API_Hole_HideHole.
windowMode 10
Window display definition.
Possible values: API_Hole_ShowWithDim, API_Hole_ShowOnPlan, API_Hole_HideOnPlan, API_Hole_ReflCeiling, API_Hole_HideHole.
skylightMode 15
API_Hole_ShowWithDim…API_Hole_HideHole.
sectionMarker
Specifies the section markers visibility (Archicad only).
API_Section_Marker_Normal Section Markers are fully displayed on the floor plan.
API_Section_Marker_KeyPlan Section Markers are displayed with only one marker at the midpoint between the two ends of the imaginary Section Line.
API_Section_Marker_AsInSettings Section Markers are displayed as they are set in the Section Settings dialog box.
beamMethod
Specifies the beam drawing style (Archicad only).
Possible values: API_Beam_Drawing_Full, API_Beam_Drawing_RefLine, API_Beam_Drawing_Contour.
roofShellMode 15
API_RoofShellShow_AllDetails, API_RoofShellShow_TopSurface, API_RoofShellShow_ContourDrawing.
showColumnSymbol 6.1
Specifies whether column symbols are displayed on the floor plan (Archicad only).
Possible values: API_Column_Symbol_Hide, API_Column_Symbol_Show.
slabMethod
For adjoining slabs with the same top surface and top height.
Possible values: API_Slab_ShowCommonEdges, API_Slab_EliminateCommonEdges, API_Slab_HiddenCommonEdges.
coluHiddenlineUnderSlabs
Use hidden line under slab in columns.
beamHiddenlineUnderSlabs
Use hidden line under slab in beams.
showMarkupItems
Tells whether mark-up items should be visible.
zoneHideZoneStamp 12
Tells whether the zone stamps should be visible.
curtainWallModelViewOptions 22
Structure of Curtain Wall Model View Options.
stairModelViewOpions 21
Structure of Stair Model View Options.
railingModelViewOpions 21
Railing Model View Options.
gdlOptions 12
Array of GDL related view options (GSPtr). It has an effect only on library part based elements’ appearence (window, door, object, lamp).

 

Remarks

These settings correspond to the relevant items in the Document/Set Model View/Model View Options dialog.

Model view options are also part of the navigator view definition.

Call the ACAPI_Environment function with the APIEnv_GetViewOptionsID or APIEnv_ChangeViewOptionsID function codes to operate on this data.

Do not forget to dispose the gdlOptions pointer when it is not needed any more. Refer to the ACAPI_FreeGDLModelViewOptionsPtr to do that.

 

Requirements

Version: API 10 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetViewOptionsID, APIEnv_ChangeViewOptionsID,
API_NavigatorView,
API Types