Control information of a custom data section saved into the project file.
typedef struct { Int32 dataVersion; unsigned short platformSign; short filler_1; GSHandle dataHdl; Int32 filler_2 [11]; } API_ModulData;
Members
- dataVersion
- Data version; use this for backward compatibility.
- platformSign
- Byte ordering in data storage (can be either
GS::Win_Platform_Sign
,GS::Mac_Platform_Sign
orGS::Mactel_Platform_Sign
). Use this to handle cross-platform issues.
- dataHdl
- User specified data (cannot be
nullptr
).
Remarks
This structure is used by the ModulData Manager functions, for further details refer to these sections.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_ModulData.h
See Also
ACAPI_ModulData_GetInfo
ACAPI_ModulData_Get
ACAPI_ModulData_Store
APIModulDataMergeHandlerProc
ModulData Manager
API Types