API_​ModulID

Unique identifier of an add-on.

    typedef struct {
        GSType     developerID;
        GSType     localID;
    } API_ModulID;

 

Members

developerID
the unique ID of the add-on developer. Generated by Graphisoft upon registration.
localID
local add-on identifier. The developer is responsible to select different local IDs 

 

Remarks

This structure refers to the ‘MDID’ resource.

The data structure is used directly by the Communication Manager, to identify the target add-on. The add-on unID is also used by the ModulData Manager to identify the owners of the custom data sections saved into the project files.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Registration.h

 

See Also

ACAPI_Command_Test
ACAPI_Command_Call
Communication Manager
ModulData Manager
‘MDID’
API Types