Represents the data of a monolithic Stair Structure element.
typedef struct { bool thinning; bool materialsChained; short filler_1; API_AttributeIndex sideFill; API_AttributeIndex buildingMaterial; short filler_2[2]; double monolithThickness; double bottomOversize; API_OverriddenAttribute topMaterial; API_OverriddenAttribute leftMaterial; API_OverriddenAttribute rightMaterial; API_OverriddenAttribute bottomMaterial; API_AttributeIndex cutLineType; short cutLinePen; short pen; API_AttributeIndex lineType; short filler_3[2]; API_OverriddenAttribute cutFillPen; API_OverriddenAttribute cutFillBackPen; API_AttributeIndex surfaceMaterial; bool uniformDrainings; bool filler_4[3]; API_StairStructureDrainingData draining[API_StairDrainSideNum]; } API_MonolithStairStructData;
Members
- thinning
- True, if the structure is thinned.
- materialsChained
- True, if the structure’s materials are chained.
- sideFill
- The fill of the building material.
- buildingMaterial
- The index of the structure’s building material.
- filler_1
- UNUSED PARAMETER
- monolithThickness
- The thickness of the monolith.
- bottomOversize
- The size of the horizontal bottom.
- topMaterial
- The top material of the structure.
- leftMaterial
- The left side material of the structure.
- rightMaterial
- The right side material of the structure.
- bottomMaterial
- The bottom material of the structure.
- cutLinePen
- The index of the cut parts’ 2D representation’s pen.
- cutLineType
- The index of the cut parts’ 2D representation’s line type.
- pen
- The index of the 2D representation’s pen.
- lineType
- The index of the 2D representation’s line type.
- cutFillPen
- The cut fill pen of the Stair Structure.
- cutFillBackPen
- The cut fill background pen of the Stair Structure.
- surfaceMaterial
- The Stair Structure’s surface material.
- uniformDrainings
- Uniform Drainings on left and right side.
- draining
- Data about the Stair Structure’s drainings.
APIDS_Left
Draining on the left side.
APIDS_Right
Draining on the right side.
Requirements
- Version: API 21 or later
- Header: APIdefs_Elements.h
See Also
API_AttributeIndex
API_Element,
API_StairType,
API_StairStructureType
Element Manager,
API Types