API_​MorphQuantity

Returns the morph quantity values.

    typedef struct {
        double     surface;
        double     volume;
        double     floorPlanArea;
        double     floorPlanPerimeter;
        double     baseLevel;
        double     baseHeight;
        double     wholeHeight;
        UInt32     nodesNr;
        UInt32     edgesNr;
        UInt32     hiddenEdgesNr;
        UInt32     softEdgesNr;
        UInt32     visibleEdgesNr;
        UInt32     facesNr;
        double     filler_1[8];
    } API_MorphQuantity;

 

Members

surface
Net area of the body surface.
volume
Net volume of the body.
floorPlanArea
Net area of the floor plan projection.
baseLevel
Elevation.
baseHeight
The height range from the lowest point of inward-sloping faces to the highest point within the story height, relative to the story.
wholeHeight
Height of the morph.
floorPlanPerimeter
Perimeter of the floor plan projection.
nodesNr
Number of the nodes of the body.
edgesNr
Number of the edges of the body.
hiddenEdgesNr
Number of the hidden edges of the body.
softEdgesNr
Number of the soft edges of the body.
visibleEdgesNr
Number of the visible edges of the body.
facesNr
Number of the faces of the body.

 

Requirements

Version: API 16 or later
Header: APIdefs_Elements.h

 

See Also

API Types